Module Download

You can download the module from here

You need Joomla! 2.5 to see this module working

 

Click Here to get the Joomla! OpenStreetMaps module version 1.0